Go Back   The Navara Forum > D40 > D40 General Chat

Reply
 
Thread Tools Display Modes

  #11  
Old 12-01-2017, 12:41 PM
manxdune manxdune is offline
Junior Member
 
Join Date: Jan 2017
Location: Perth
Posts: 5
Default

Quote:
Originally Posted by Boogieboots View Post
I can't help you but I gotta ask. Have you got a Manx beach buggy?
Haha yep :)
Meyers Manx Registered
Reply With Quote
Sponsored Links

  #12  
Old 12-01-2017, 12:49 PM
Old.Tony's Avatar
Old.Tony Old.Tony is offline
Administrator
 
Join Date: Oct 2009
Location: Mid Coast Region, NSW, Australia
Posts: 14,707
My Mood:
Garage
Default

I agree with the above. Definitely sounds like a rust inhibitor. The heatsink is probably for show - you wouldn't want a rust inhibitor that drew so much power that it needed a heatsink to shed the excess heat!
__________________

Check out the FAQs by clicking here!

Visit the Australian National Navara Muster website: www.navaramuster.com.au

"Unfortunately we live in a society where pizza gets to your house faster than the police can."
Reply With Quote

  #13  
Old 21-04-2017, 01:44 PM
Boogieboots's Avatar
Boogieboots Boogieboots is offline
Member
 
Join Date: Jun 2016
Location: Byford WA
Posts: 159
Garage
Default

A few months later, but me too! Was my first car. Is in need of restoration now though

Sent from my GT-I9505 using Tapatalk
__________________
2005 d22 Dual Cab ZD30, 280k and counting....
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT +1. The time now is 12:11 AM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
| Home | Register | FAQ | Members List | Calendar | Today's Posts | Search | New Posts |