Go Back   The Navara Forum > D22 > D22 Engine

Reply
 
Thread Tools Display Modes

D22 0407 and 0707
  #1  
Old 19-01-2020, 08:04 AM
tristan.martin564 tristan.martin564 is offline
Junior Member
 
Join Date: Sep 2019
Location: port augusta
Posts: 25
Default D22 0407 and 0707

was able to find out what codes the car has and have no clue what to do from here. nissan couldnít figure it out so iím pretty much left here on my own. comes back with Crankshaft position sensor and injection pump injection timing control. what couldíve caused this to happen?


Sent from my iPhone using Tapatalk
Reply With Quote
Sponsored Links

  #2  
Old 19-01-2020, 08:15 AM
tristan.martin564 tristan.martin564 is offline
Junior Member
 
Join Date: Sep 2019
Location: port augusta
Posts: 25
Default

just reset the codes and took for a drive around the block, light came back on and now only displays error code 0707 and 0407 has gone away.


Sent from my iPhone using Tapatalk
Reply With Quote

  #3  
Old 19-01-2020, 11:55 AM
Rumpig's Avatar
Rumpig Rumpig is offline
Advanced Member
 
Join Date: Aug 2009
Location: W.A
Posts: 1,549
Garage
Default

0707 is most commonly caused by air getting in to the fuel pump which throws out the start of injection timing. Put some clear 10mm hose on both sides of the fuel filter and look for air bubbles in the fuel.
__________________
"A little information is a dangerous thing"
Reply With Quote

  #4  
Old 19-01-2020, 12:24 PM
tristan.martin564 tristan.martin564 is offline
Junior Member
 
Join Date: Sep 2019
Location: port augusta
Posts: 25
Default

Quote:
Originally Posted by Rumpig View Post
0707 is most commonly caused by air getting in to the fuel pump which throws out the start of injection timing. Put some clear 10mm hose on both sides of the fuel filter and look for air bubbles in the fuel.
How can i connect the clear hose? or just completely replace the old hose with clear?
Reply With Quote

  #5  
Old 19-01-2020, 02:34 PM
Boogieboots's Avatar
Boogieboots Boogieboots is offline
Member
 
Join Date: Jun 2016
Location: Byford WA
Posts: 285
My Mood:
Garage
Default

Just insert a clear section temporarily or replace. I was getting 0407 CAS fault. Car was hard to start, cranking heaps with tacho bouncing. One started was fine. Turned out to be the starter causing interference and triggering CAS fault. If this isn't what you as seeing then try rums trick. Pump up primer before starting perhaps also, that may give some indication of air getting in if you need to pump it heaps
__________________
2005 d22 Dual Cab ZD30, 280k and counting....
Reply With Quote

  #6  
Old 19-01-2020, 10:15 PM
tristan.martin564 tristan.martin564 is offline
Junior Member
 
Join Date: Sep 2019
Location: port augusta
Posts: 25
Default

Quote:
Originally Posted by Boogieboots View Post
Just insert a clear section temporarily or replace. I was getting 0407 CAS fault. Car was hard to start, cranking heaps with tacho bouncing. One started was fine. Turned out to be the starter causing interference and triggering CAS fault. If this isn't what you as seeing then try rums trick. Pump up primer before starting perhaps also, that may give some indication of air getting in if you need to pump it heaps


cheers, the car did have the 0407 and itís still hard for it to start in the morning


Sent from my iPhone using Tapatalk
Reply With Quote

  #7  
Old 20-01-2020, 10:15 AM
tweak'e's Avatar
tweak'e tweak'e is offline
Advanced Member
 
Join Date: Oct 2008
Location: New Zealand
Posts: 4,576
Garage
Default

7070 is injection pump failed to achieve timing. commonly caused by blocked up fuel filter or air being sucked into the fuel line. common place is the fuel filter and fuel filter primer.
clear hose is handy trick.
a small trick is to fit a one way in the fuel line back at the tank. that stops fuel draining back to tank and cause hard starts in the morning.
also fitting a diesel lift pump helps a fair bit.
however worse case is its an injection pump issue as the timing piston is known to wear.

with crank sensor check its not full of mud etc. it is known to have issue with interference. i think someone found problems caused by a relay arcing a bit.
__________________
D22 ZD30 egr+butterfly mod, 2" lift extra leaf springs, enk-tek dump pipe, 2.5" exhaust.
D23 no mods.......yet.
single cab workhorse, to muddy to clean
Reply With Quote

  #8  
Old 03-02-2020, 05:39 AM
Horatius Horatius is offline
Member
 
Join Date: Sep 2016
Location: Aus
Posts: 217
Default

How did you go with this? Sorted out?

Only time I have ever had that fault code is from blocked filter/dirty fuel.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT +1. The time now is 10:46 PM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
| Home | Register | FAQ | Members List | Calendar | Today's Posts | Search | New Posts |