Go Back   The Navara Forum > D40 > D40 General Chat

Reply
 
Thread Tools Display Modes

Airbag Light Flashing
  #1  
Old 25-10-2019, 04:49 AM
Dazza63's Avatar
Dazza63 Dazza63 is offline
Junior Member
 
Join Date: Jun 2019
Location: Australia
Posts: 21
Default Airbag Light Flashing

I went out to start my 2008 D40 about 4 days ago and the air bag light continually flashes just came on over night. I did a bit of research found the turn key on till light flashes then turn off wait 5 secs turn back on. Repeat this 3 times to reset the air bag light. It didn't work at all. Had it booked in to go to Auto Electrician went to go and the light was off. I went to shops came out started it flashing again has been ever since. Went to a friends house the next day got fuel started the car and the oil light started to flash but it went off. It has oil in it full no idea why.
Any ideas or things I can try to sort issue thanks folks for any help sent. I appreciate it..
Reply With Quote
Sponsored Links

  #2  
Old 25-10-2019, 12:30 PM
amber.2's Avatar
amber.2 amber.2 is offline
Member
 
Join Date: Jan 2012
Location: Robina Gold Coast QLD
Posts: 200
Default

Was your vehicle part of the Airbag recall ?
Reply With Quote

  #3  
Old 25-10-2019, 09:39 PM
Old.Tony's Avatar
Old.Tony Old.Tony is offline
Administrator
 
Join Date: Oct 2009
Location: Mid Coast Region, NSW, Australia
Posts: 15,200
My Mood:
Garage
Default

There may be two problems here. If not, it might just be a glitch caused by a poor electrical connection (clean the battery terminals and ECU ground wire).

Check the oil switch connection. The switch is located in the middle of the engine on the right hand side just forward of the oil coooler (which is just below the oil filter). Disconnect, clean, reconnect.

The airbag light could be one of two things: a broken clock spring (highly likely, happened to me several times) or a failing diagnostic unit (this has happened to me as well). Remove and test the clock spring for continuity across the ribbon cable within and if the cable is good, there's a good chance the diagnostic unit is faulty.

Getting a diagnostic unit from a wreck is acceptable (over $1K from Nissan, I paid $100 at a wrecker). The unit lives on the transmission tunnel under the cup holders.

You could also try a clock spring from a wreck as well, but if you're handy, the ribbon cables are cheap on eBay. If you replace the clock spring, make absolutely certain that the unit has a large "R" in the plastic of the main face, if it has an "L" like most of the $20-odd units on eBay, it's for a left-hand drive vehicle and the indicator cancellation will work weird (I made this mistake myself).
__________________

Check out the FAQs by clicking here!



"Money can't buy happiness, but it does make misery a lot easier to deal with."
Reply With Quote

  #4  
Old 30-10-2019, 10:33 AM
Dazza63's Avatar
Dazza63 Dazza63 is offline
Junior Member
 
Join Date: Jun 2019
Location: Australia
Posts: 21
Default

Thanks guys for replies it was clock spring $245 for clock spring and $300 scanning and labour. Extortion. The worst thing is I replaced it only about 4mnths ago and its gone again not happy but fixed now I hope. But thanks for replies greatly appreciated....The one I bought online cost me $50 but oh well you only get what you pay for...

Last edited by Dazza63; 30-10-2019 at 10:35 AM.
Reply With Quote

  #5  
Old 30-10-2019, 08:50 PM
Old.Tony's Avatar
Old.Tony Old.Tony is offline
Administrator
 
Join Date: Oct 2009
Location: Mid Coast Region, NSW, Australia
Posts: 15,200
My Mood:
Garage
Default

Hot tip:

When replacing the clock spring, BEFORE installation, you should remove the locking plug and turn the inner part both ways, keeping count of how many full rotations it does.

You should be able to get almost 3 full rotations from centre in each direction. If you can't, the clock spring was set incorrectly, and it will break after installation.

The old clock spring can be rebuilt. I've even repaired damaged ribbon cables and the unit in my car is over a year old and still going strong.
__________________

Check out the FAQs by clicking here!



"Money can't buy happiness, but it does make misery a lot easier to deal with."
Reply With Quote

  #6  
Old Yesterday, 06:17 AM
allaroundoz allaroundoz is offline
Junior Member
 
Join Date: Oct 2019
Location: Sydney
Posts: 21
Default

Same issue here since todayís morning. Seems like my Navara is collecting every possible fault. 🤮 But after having spent 3K and wasted 1 month of our travel I donít wanna end up near a workshop anymore.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT +1. The time now is 02:59 AM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
| Home | Register | FAQ | Members List | Calendar | Today's Posts | Search | New Posts |