Go Back   The Navara Forum > D22 > D22 Engine

Reply
 
Thread Tools Display Modes

ZD30 Injector Pump Advice
  #1  
Old 14-06-2014, 06:51 PM
qvanzyl qvanzyl is offline
Junior Member
 
Join Date: Nov 2010
Posts: 1
Default ZD30 Injector Pump Advice

Hey Guys

Wonder if anyone can assist me or give me some advice,

I put some diesel in my ZD30, Got on the highway and the next moment i lost power and had covered the highway in a james bond style smoke screen. Anyway stopped the vehicle and noticed a rough idle

My first though was stuck injector, had the vehicle towed home and started diagnosing the problem, i have done the following

Compression test - OK
Check oil in coolent - No Oil in coolent
Check for coolent in oil - No coolent in oil
Oil level - did not rise at all

Sent Injectors in to get serviced, Guy said ther was nothing wrong with them, they spray perfectly, Re-installed the injectors but i still have arough idle. Next i cracked each of the injector nuts while the ingine was running and saw that they all spray strong except Nr4

Nr4 cylinder does not seem to get enough diesel.

My Question is,

Can this be a blockage due to water getting into my injector pump? (No ECU warning by the way)

Would i need to start shopping for a new pump - Damm i hope not. ?

It is only the NR4 cylinder that is had weak pressure, any reason for this, i was under the impression that if the pump fails it does not have any pressure (Or very little in all the cylinders)

My Diesel mec said i should try putting in some additive that will dissolve water present in the fuel and see if it will possibly clear the blockage (If any)

Thanks guys i really appreciate any feedback/advice

Cheers
Reply With Quote
Sponsored Links

  #2  
Old 14-06-2014, 11:09 PM
Old.Tony's Avatar
Old.Tony Old.Tony is offline
Administrator
 
Join Date: Oct 2009
Location: Mid Coast Region, NSW, Australia
Posts: 14,914
My Mood:
Garage
Default

Welcome to the forum.

I wonder if there's a problem with the supply line to the injector - either damage, or it's got algae or something in it? A fuel additive that handles water and algae won't hurt. If you've been somewhere really cold you might have some wax formed in there.

I've not heard of any particular fault with the ZD30 where one injector gets less fuel pressure than others, so a blockage or damage would seem probable.
__________________

Check out the FAQs by clicking here!



"Money can't buy happiness, but it does make misery a lot easier to deal with."
Reply With Quote

  #3  
Old 15-06-2014, 01:55 AM
Rumpig's Avatar
Rumpig Rumpig is offline
Advanced Member
 
Join Date: Aug 2009
Location: Darwin
Posts: 1,525
Garage
Default

Agree with Old Tony, probably something stuck in the pump outlet or line. Here's some links on how the vp44 works. http://dodgeram.org/tech/dsl/ISB/Vp44.htm http://www.bluechipdiesel.com/vp44_diagnostics.html
__________________
"A little information is a dangerous thing"
Reply With Quote

  #4  
Old 15-06-2014, 04:30 AM
tweak'e's Avatar
tweak'e tweak'e is offline
Advanced Member
 
Join Date: Oct 2008
Location: New Zealand
Posts: 4,478
Garage
Default

what color smoke did it make?

cracking an injector nut is fairly tricky to get the same opening on all injectors. no4 you may have opened up to much or to little and got a different spray pattern.
only way to confirm its pump is to bench test it.
only place a single line could loose pressure is the check valve.

any water in the fuel filter?
__________________
D22 ZD30 egr+butterfly mod, 2" lift extra leaf springs, enk-tek dump pipe, 2.5" exhaust.
D23 no mods.......yet.
single cab workhorse, to muddy to clean
Reply With Quote

  #5  
Old 11-07-2018, 11:42 AM
Been a while Been a while is offline
Member
 
Join Date: Dec 2017
Location: qld
Posts: 153
My Mood:
Default

What happens to the rest of these posts? Or is this it?
Reply With Quote

  #6  
Old 12-07-2018, 10:38 AM
Old.Tony's Avatar
Old.Tony Old.Tony is offline
Administrator
 
Join Date: Oct 2009
Location: Mid Coast Region, NSW, Australia
Posts: 14,914
My Mood:
Garage
Default

Quote:
Originally Posted by Been a while View Post
What happens to the rest of these posts? Or is this it?
Nothing's been deleted from the thread, so this is it (so far).
__________________

Check out the FAQs by clicking here!



"Money can't buy happiness, but it does make misery a lot easier to deal with."
Reply With Quote

  #7  
Old 12-07-2018, 11:24 AM
bods's Avatar
bods bods is offline
Advanced Member
 
Join Date: Sep 2010
Location: Orelia, WA
Posts: 4,682
Default

Most of them are never followed up....

Sent from my SM-T813 using Tapatalk
Reply With Quote

  #8  
Old 13-07-2018, 11:03 PM
Been a while Been a while is offline
Member
 
Join Date: Dec 2017
Location: qld
Posts: 153
My Mood:
Default

Ahh thanks, dont ya hate it...
Reply With Quote

  #9  
Old 14-07-2018, 10:52 AM
Old.Tony's Avatar
Old.Tony Old.Tony is offline
Administrator
 
Join Date: Oct 2009
Location: Mid Coast Region, NSW, Australia
Posts: 14,914
My Mood:
Garage
Default

Yeah but that's not unusual.

If it's the VP44 pump there are dozens of forums with hundreds of posts with lengthy descriptions of how bad that sucker can be. Does anyone know if the ZD30 has that pump or is it something non-Bosch?
__________________

Check out the FAQs by clicking here!



"Money can't buy happiness, but it does make misery a lot easier to deal with."
Reply With Quote

  #10  
Old 14-07-2018, 11:50 AM
bods's Avatar
bods bods is offline
Advanced Member
 
Join Date: Sep 2010
Location: Orelia, WA
Posts: 4,682
Default

Yep, the zd30 in the Navara has the lovely vp44 too, same as the patrol.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT +1. The time now is 08:25 PM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
| Home | Register | FAQ | Members List | Calendar | Today's Posts | Search | New Posts |