Go Back   The Navara Forum > D40 > D40 Engine

Reply
 
Thread Tools Display Modes

D40 Navara DPF, CAT, MODS etc...
  #1  
Old 21-09-2011, 07:08 AM
4BYFOR's Avatar
4BYFOR 4BYFOR is offline
Advanced Member
 
Join Date: Jan 2010
Location: Brisbane Queensland
Posts: 1,468
My Mood:
Garage
Default D40 Navara DPF, CAT, MODS etc...

Hello everyone! Well after doing alot of reasearch and trying different things I thought that I would share some of the things that I have been doing on my Navara and hope that this will solve alot of problems for you that I have already gone through...
Ok so what I have done to remove the factory CAT and DPF without having anymore warning lights white smoke etc..
I had a 3" DPF back exahust system installed and had no issues there but my fuel compsumption was terrible! So I had decided to go ahead and remove the whole lot. I started by punching out the CAT guts and had sucuess doing so but it didn't do much just blew a heap of smoke when it was doing a regen cycle so I jumped on here and seen that someone had unhooked their presure sensor to shut down the DPF, what a big F%&*%ing mistake that was.. DPF light came on (death light) I was driving fine for about 2 weeks then BANG limp mode.. I had tried everything it went into Nissan and they tried 5 regens to clear it without sucuess it was FULLY BLOCKED.. Just so you know a new DPF is about $2000 - $3000 F*%#K that. SO after towing my car from where I broke down to Nissan then back to my house I took off the DPF and cut it open removed the guts and got it welded back up for $20. Back to Nissan! Before I did this I asked the mechanic what can I do?! He bascially said the only way to clear the limop mode is to put a new DPF and master reset the computer... OK now finally some light at the end of the tunnel got me thinking to get out of it the cheap way because I need my ute for work is to remove the guts out of the damn thing and get the computer reset.. Ok all done car was working finally after a week off the road.. Not CAT no DPF. SO what I have done now is get a 3" dump pipe turbo back 3" pipe all the way through but I had to get a 3" resinator on the thing after a week it was so loud sounded like a monstor truck. I had to get the fittings made up that the old DPF had except the presure sensors. Reason being. The presure sensors did not need to be plumbed back in but just plumbed togeather so they read the same presure. I will get photos up of the mods done and now that I know people that can make all the bits and peices if you are interested in doing this to your car I can get you all the parts. Anyway I don't have a regen cycle anymore due to the fact that once the computer is reset thinking there is a new DPF with all the new piping in place it willl never read that it's full. No white smoke! So once you have done all your mods just take it to nissan straight away and get a computer reset should only cost you $80 i'd say. Not too sure how muich but mine was alot more costly. The reason I have posted this up is because this is the best way to eliminate any problems like how I had. I will be posting photos and more information on this post as there are too many to keep track of for mods. I hope this helps people out wish I had this post when I was in limp mode

Click image for larger version

Name:	dpf1.jpg
Views:	2023
Size:	109.5 KB
ID:	4532

Click image for larger version

Name:	dpf2.jpg
Views:	4983
Size:	117.9 KB
ID:	4533

Click image for larger version

Name:	dpf3.jpg
Views:	1852
Size:	107.6 KB
ID:	4534

Click image for larger version

Name:	dpf4.jpg
Views:	1508
Size:	128.9 KB
ID:	4535

Click image for larger version

Name:	dpf5.jpg
Views:	1662
Size:	107.7 KB
ID:	4536
__________________
Black Nissan Navara 2007 STX D40 2.5td 3" turbo back exaust system, upgraded intercooler and pipe work, EGR blanking plate installed, Unichip with iDrive with 5way map switch, k&n apollo air filter, snorkel, coopers xeon all terrains riding on 20" rims, 5% tint all round, load puls rear extra leaf spring, HID HALO projector lights, custom grill and slotted X drilled rotors, boost gauge and JVC double din head unit, 12" alpine sub with rockford fosgate amps! BOOM

Last edited by 4BYFOR; 21-09-2011 at 09:13 AM.
Reply With Quote
Sponsored Links

  #2  
Old 21-09-2011, 08:47 AM
Bosshog's Avatar
Bosshog Bosshog is offline
Advanced Member
 
Join Date: Feb 2009
Location: Australia
Posts: 1,343
My Mood:
Default

Hi 4Byfor

If I am reading your post correctly and I am sure I am coz the pics verify it, you have removed both your DPF and your factory dump pipe and cat.

That being the case your ute will blow white smoke within 200-300 kms unless you drive it regularly at highway speed. If you are driving it around a built up suburban area I guarantee you white smoke will appear.

I have stepped my O2 sensor out and while that has not 100% fixed the white smoke it only does a what I call a 'half burn'. The EGTs goes up and you can smell the unburnt diesel but there is little or no smoke.
__________________
She's sold and my time here has ended.

Thanks everyone for your support and all the best in whatever you do!
Reply With Quote

  #3  
Old 21-09-2011, 09:18 AM
4BYFOR's Avatar
4BYFOR 4BYFOR is offline
Advanced Member
 
Join Date: Jan 2010
Location: Brisbane Queensland
Posts: 1,468
My Mood:
Garage
Default

Yes bosshog, I have done that also must have forgot to add that into my post.. made a 3mm hole at the end of the bung and its spaced out about 5mm from the tip of the probe. I am on my 4th full tank of diesel and i have not seen any smoke besides take off which is quite normal.. but when I was blowing white smoke before my car died in the ass you could really see a cloud..
__________________
Black Nissan Navara 2007 STX D40 2.5td 3" turbo back exaust system, upgraded intercooler and pipe work, EGR blanking plate installed, Unichip with iDrive with 5way map switch, k&n apollo air filter, snorkel, coopers xeon all terrains riding on 20" rims, 5% tint all round, load puls rear extra leaf spring, HID HALO projector lights, custom grill and slotted X drilled rotors, boost gauge and JVC double din head unit, 12" alpine sub with rockford fosgate amps! BOOM

Last edited by 4BYFOR; 21-09-2011 at 09:21 AM.
Reply With Quote

  #4  
Old 21-09-2011, 10:49 AM
SimonD40's Avatar
SimonD40 SimonD40 is offline
Member
 
Join Date: Mar 2011
Location: Anna Bay
Posts: 72
My Mood:
Garage
Send a message via Skype™ to SimonD40
Default

Quote:
Originally Posted by 4BYFOR View Post
Hello everyone! Well after doing alot of reasearch and trying different things I thought that I would share some of the things that I have been doing on my Navara and hope that this will solve alot of problems for you that I have already gone through...
Ok so what I have done to remove the factory CAT and DPF without having anymore warning lights white smoke etc..
I had a 3" DPF back exahust system installed and had no issues there but my fuel compsumption was terrible! So I had decided to go ahead and remove the whole lot. I started by punching out the CAT guts and had sucuess doing so but it didn't do much just blew a heap of smoke when it was doing a regen cycle so I jumped on here and seen that someone had unhooked their presure sensor to shut down the DPF, what a big F%&*%ing mistake that was.. DPF light came on (death light) I was driving fine for about 2 weeks then BANG limp mode.. I had tried everything it went into Nissan and they tried 5 regens to clear it without sucuess it was FULLY BLOCKED.. Just so you know a new DPF is about $2000 - $3000 F*%#K that. SO after towing my car from where I broke down to Nissan then back to my house I took off the DPF and cut it open removed the guts and got it welded back up for $20. Back to Nissan! Before I did this I asked the mechanic what can I do?! He bascially said the only way to clear the limop mode is to put a new DPF and master reset the computer... OK now finally some light at the end of the tunnel got me thinking to get out of it the cheap way because I need my ute for work is to remove the guts out of the damn thing and get the computer reset.. Ok all done car was working finally after a week off the road.. Not CAT no DPF. SO what I have done now is get a 3" dump pipe turbo back 3" pipe all the way through but I had to get a 3" resinator on the thing after a week it was so loud sounded like a monstor truck. I had to get the fittings made up that the old DPF had except the presure sensors. Reason being. The presure sensors did not need to be plumbed back in but just plumbed togeather so they read the same presure. I will get photos up of the mods done and now that I know people that can make all the bits and peices if you are interested in doing this to your car I can get you all the parts. Anyway I don't have a regen cycle anymore due to the fact that once the computer is reset thinking there is a new DPF with all the new piping in place it willl never read that it's full. No white smoke! So once you have done all your mods just take it to nissan straight away and get a computer reset should only cost you $80 i'd say. Not too sure how muich but mine was alot more costly. The reason I have posted this up is because this is the best way to eliminate any problems like how I had. I will be posting photos and more information on this post as there are too many to keep track of for mods. I hope this helps people out wish I had this post when I was in limp mode

Attachment 4532

Attachment 4533

Attachment 4534

Attachment 4535

Attachment 4536
Great Work Keep us all posted I am very interested.
__________________
Simon
D40 ST-X
Dual cab, 2.5 Auto, 265/75/16 MT ATZ's, K&N filter,Chipit Delete pipe, ORS Drawers, ARB Canopy, 2"lift.
Reply With Quote

  #5  
Old 21-09-2011, 03:41 PM
SideStep SideStep is offline
Member
 
Join Date: Dec 2010
Posts: 103
My Mood:
Default

WOW some of you blokes know your shiit!
I know how to make mine bling that's about it haha
Reply With Quote

  #6  
Old 11-05-2013, 01:45 PM
Ash2009stx's Avatar
Ash2009stx Ash2009stx is offline
Junior Member
 
Join Date: Mar 2013
Location: Weipa, QLD
Posts: 10
Garage
Default

Hey 4BYFOR, I think my D40 went into limp mode today whilst the DPF light was on. Can you confirm the symptoms of limp mode being that speed is limited to 80-90km/h and a suffocating noise from the engine if rev'd past 3500? It seemed like the engine was unable to breath and there was no acceleration past 80-90km/h regardless of pedal.

I pulled over immediately and inspected the vehicle and when I stated the vehicle again the problem was gone???

Is this caused by that F#cking DPF?
Reply With Quote

  #7  
Old 12-05-2013, 12:37 AM
4BYFOR's Avatar
4BYFOR 4BYFOR is offline
Advanced Member
 
Join Date: Jan 2010
Location: Brisbane Queensland
Posts: 1,468
My Mood:
Garage
Default

It could be mate but I'm pretty sure if you got it up and going again you drove it for a good 15min to complete the regen? Did the dpf light turn off?
__________________
Black Nissan Navara 2007 STX D40 2.5td 3" turbo back exaust system, upgraded intercooler and pipe work, EGR blanking plate installed, Unichip with iDrive with 5way map switch, k&n apollo air filter, snorkel, coopers xeon all terrains riding on 20" rims, 5% tint all round, load puls rear extra leaf spring, HID HALO projector lights, custom grill and slotted X drilled rotors, boost gauge and JVC double din head unit, 12" alpine sub with rockford fosgate amps! BOOM
Reply With Quote

  #8  
Old 12-05-2013, 01:27 PM
Jazz Jazz is offline
Member
 
Join Date: Jan 2011
Posts: 51
Default

Hey 4BYFOR,

Are you saying that when the computer is told the vehicle has a NEW DPF it will not trigger the 300km regen? it will only trigger when the pressure sensors tell it to?

So by removing the DPF and telling the computer you have fitted a new one, the computer will always be waiting for the pressure differential and will never regen/whitesmoke.

When a new DPF has been fitted maybe the computer doesnt do the 300km regen untill the DPF pressure sensors has told it it needs its first regen. Maybe a new DPF is assumed takes a while to clog up so the standard 300km regen is not needed at the start of its life....Maybe maybe??
Reply With Quote

  #9  
Old 13-05-2013, 11:25 AM
4BYFOR's Avatar
4BYFOR 4BYFOR is offline
Advanced Member
 
Join Date: Jan 2010
Location: Brisbane Queensland
Posts: 1,468
My Mood:
Garage
Default

Pretty much mate
__________________
Black Nissan Navara 2007 STX D40 2.5td 3" turbo back exaust system, upgraded intercooler and pipe work, EGR blanking plate installed, Unichip with iDrive with 5way map switch, k&n apollo air filter, snorkel, coopers xeon all terrains riding on 20" rims, 5% tint all round, load puls rear extra leaf spring, HID HALO projector lights, custom grill and slotted X drilled rotors, boost gauge and JVC double din head unit, 12" alpine sub with rockford fosgate amps! BOOM
Reply With Quote

  #10  
Old 13-05-2013, 11:38 AM
Jazz Jazz is offline
Member
 
Join Date: Jan 2011
Posts: 51
Default

Quote:
Originally Posted by 4BYFOR View Post
Pretty much mate
Interesting...

I was quoted about $1600 to have the computer re-programed to remove the DPF regen cycle.

You method could be a cheaper option with the same result.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT +1. The time now is 10:47 PM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
| Home | Register | FAQ | Members List | Calendar | Today's Posts | Search | New Posts |