Go Back   The Navara Forum > D40 > D40 General Chat

Reply
 
Thread Tools Display Modes

  #11  
Old 10-04-2014, 07:11 AM
maria maria is offline
Junior Member
 
Join Date: Apr 2014
Posts: 3
Default

That is what was happening to my Nissan d40 we took it to the dealer and they said nothing wrong with it Now it has snapped the timing chain and we r up for big bucks to change the motor my suggestion is go to the dealer ASAP I wouldn't want what happen to us to happen to you as well
Reply With Quote
Sponsored Links

  #12  
Old 11-04-2014, 03:21 AM
rondoppla rondoppla is offline
Junior Member
 
Join Date: Apr 2014
Location: australia
Posts: 7
Default

thanks mate, the engine is now running quieter and smoother. would you recommend putting the ecu into learning mode after something like this?
Reply With Quote

  #13  
Old 11-04-2014, 04:42 AM
shaunus88 shaunus88 is offline
Member
 
Join Date: May 2013
Location: Western Australia
Posts: 111
Default

I would suggest it yes. Good to hear!
Reply With Quote

  #14  
Old 11-04-2014, 04:44 AM
EVLSTX EVLSTX is offline
Banned
 
Join Date: Apr 2013
Location: Melbourne. Victoria
Posts: 122
Send a message via Skype™ to EVLSTX
Default

maf sensor?
Reply With Quote
Reply

Tags
no power, noise, reduced power

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT +1. The time now is 12:29 AM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
| Home | Register | FAQ | Members List | Calendar | Today's Posts | Search | New Posts |