Go Back   The Navara Forum > D22 > D22 General Chat

Reply
 
Thread Tools Search this Thread Display Modes

4x4 dashboard indicator not lighting
  #1  
Old 01-04-2019, 11:05 PM
Sailorjerry13 Sailorjerry13 is offline
Junior Member
 
Join Date: Mar 2019
Location: Guadalajara, Mexico / Los Ángeles, California
Posts: 10
Default 4x4 dashboard indicator not lighting

As the title says, no 4x4 light on the dash. Took it apart and there are no bulbs, only circuits. Is there a sensor that goes out? Just wondering why the light would not work. It’s a light that is not used that often.


Sent from my iPhone using Tapatalk
Reply With Quote
Sponsored Links

  #2  
Old 02-04-2019, 12:43 AM
Old.Tony's Avatar
Old.Tony Old.Tony is offline
Administrator
 
Join Date: Oct 2009
Location: Mid Coast Region, NSW, Australia
Posts: 15,148
My Mood:
Garage
Default

It should come on when you first turn on the ignition as part of the startup diagnostics. Failing that, there is a series of steps you can do (I don't remember them just at the moment, but if we had more info about your exact model of car we could find them) that makes ALL of the instrument lights come on in test mode.
__________________

Check out the FAQs by clicking here!



"Money can't buy happiness, but it does make misery a lot easier to deal with."
Reply With Quote

  #3  
Old 02-04-2019, 11:32 PM
Sailorjerry13 Sailorjerry13 is offline
Junior Member
 
Join Date: Mar 2019
Location: Guadalajara, Mexico / Los Ángeles, California
Posts: 10
Default

Quote:
Originally Posted by Old.Tony View Post
It should come on when you first turn on the ignition as part of the startup diagnostics. Failing that, there is a series of steps you can do (I don't remember them just at the moment, but if we had more info about your exact model of car we could find them) that makes ALL of the instrument lights come on in test mode.


Sorry, i forgot to mention. Its a D22 ( mexican version np300 here). Notice the old style bed. 2.4 petrol.


Sent from my iPhone using Tapatalk
Reply With Quote

  #4  
Old 02-04-2019, 01:01 AM
bods's Avatar
bods bods is offline
Advanced Member
 
Join Date: Sep 2010
Location: Orelia, WA
Posts: 4,898
Default

Not on a d22 Tony :)

They're a bit primitive, as far as I'm aware, the 4wd light is only controlled by the 4wd switch on the side of the transfer case, when moving the 4wd lever. I'm not sure if they are leds on the cluster, but going by the description above it sounds like they are. It could be broken wiring between the switch and where the wiring goes into the cabin or a failed switch.
Reply With Quote

  #5  
Old 15-04-2019, 01:14 PM
terryc's Avatar
terryc terryc is offline
Advanced Member
 
Join Date: Oct 2010
Location: Macarthur Region, NSW.
Posts: 1,548
My Mood:
Default

Quote:
Originally Posted by Sailorjerry13 View Post
As the title says, no 4x4 light on the dash. Took it apart and there are no bulbs, only circuits.
You'll probably find that one of those "circuits" is a LED. look for a ittle stub of plastic that will sit behind the indicator light..

Just for you info.

As stated, the ight is driven from the gear selection some where. AIRI, you have to actually drive in 4x4 for it to come on and it only turns off after a few metres driving out of 4x4.
__________________
2010 D22 White Stock, sans wanky bars, plus throaty Niss nose, Niss bull bar, with flat floor in the tub and pair of upright boxes(so far).
2018 Sadly now traded.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT +1. The time now is 09:39 PM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
| Home | Register | FAQ | Members List | Calendar | Today's Posts | Search | New Posts |